Hi guys,
So over a year ago I had a PB working with OpenWRT and TP-Link MR3020. Then I did something to mess it up... Don't know what anymore. I'm trying to fix it now, but I'm a n00b, so it's hard.
Problem:
- can't connect to the wifi
- redirect to page doesn't work
I think it's something with the DHCP... but how to fix it? I forgot my telnet password (yes, stupid me), but I can ssh root into it. Some info:
root@XZIeTItv:~# vi /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'
list dns '192.168.1.1'
list dns '8.8.8.8'
option ipaddr '192.168.1.111'
root@XZIeTItv:/etc/config# vi wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option macaddr '10:fe:ed:4c:bd:86'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'PirateBox'
Does anybody know what's wrong and how to fix this?
So over a year ago I had a PB working with OpenWRT and TP-Link MR3020. Then I did something to mess it up... Don't know what anymore. I'm trying to fix it now, but I'm a n00b, so it's hard.
Problem:
- can't connect to the wifi
- redirect to page doesn't work
I think it's something with the DHCP... but how to fix it? I forgot my telnet password (yes, stupid me), but I can ssh root into it. Some info:
root@XZIeTItv:~# vi /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'
list dns '192.168.1.1'
list dns '8.8.8.8'
option ipaddr '192.168.1.111'
root@XZIeTItv:/etc/config# vi wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option macaddr '10:fe:ed:4c:bd:86'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'PirateBox'
Does anybody know what's wrong and how to fix this?