So I stumbled across this idea a week or so ago when looking for a new project. I picked myself up an MR3020 and a large flashdrive. I sat down one night and set to work setting up my new piratebox.
I got the box up and running and a new network appeared on my wifi connection screen. I successfully connected to the network with the SSID, "OpenWRT" but upon opening www.google.com and refreshing many times I was not redirected to the piratebox homepage.
I spent a week or so browsing the forums looking for similar situations to my own. I found many posts with some commands to output to make your lives easier so I've put those at the bottom of this post as well. I'm not too familiar with OpenWRT so please excuse my "noobyness".
root@OpenWrt:~# mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime,size=14592k)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,relatime,lowerdir=/,upperdir=/overlay)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/sda1 on /mnt/usb type vfat (rw,noatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
none on /proc/bus/usb type usbfs (rw,relatime)
root@OpenWrt:~# vi /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.1'
root@OpenWrt:~# ls -la /mnt/
drwxr-xr-x 1 root root 0 Jan 1 00:00 .
drwxr-xr-x 1 root root 0 Jan 1 00:00 ..
drwxrwxrwx 4 root root 512 Jan 1 00:00 usb
root@OpenWrt:~# ls -la /mnt/usb/
drwxrwxrwx 4 root root 512 Jan 1 00:00 .
drwxr-xr-x 1 root root 0 Jan 1 00:00 ..
drwxrwxrwx 2 root root 512 Jan 1 1980 external_fs
drwxrwxrwx 2 root root 512 Jan 1 1980 install
-rwxrwxrwx 1 root root 24225 Jan 1 00:00 install.log
root@OpenWrt:~# ls -la /mnt/usb/PirateBox
ls: /mnt/usb/PirateBox: No such file or directory
root@OpenWrt:~# ls -la /opt/piratebox
ls: /opt/piratebox: No such file or directory
root@OpenWrt:~# cat /opt/piratebox/version
cat: can't open '/opt/piratebox/version': No such file or directory
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option macaddr ec:08:6b:81:45:2a
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
option disabled 0
config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none
root@OpenWrt:~# dmesg | tail -n 20
[ 133.730000] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 135.730000] br-lan: port 1(eth0) entered forwarding state
[ 241.720000] eth0: link down
[ 241.720000] br-lan: port 1(eth0) entered disabled state
[ 269.720000] eth0: link up (100Mbps/Full duplex)
[ 269.720000] br-lan: port 1(eth0) entered forwarding state
[ 269.730000] br-lan: port 1(eth0) entered forwarding state
[ 271.730000] br-lan: port 1(eth0) entered forwarding state
[ 291.720000] eth0: link down
[ 291.720000] br-lan: port 1(eth0) entered disabled state
[ 1001.720000] eth0: link up (100Mbps/Full duplex)
[ 1001.720000] br-lan: port 1(eth0) entered forwarding state
[ 1001.730000] br-lan: port 1(eth0) entered forwarding state
[ 1003.730000] br-lan: port 1(eth0) entered forwarding state
[ 1421.720000] eth0: link down
[ 1421.720000] br-lan: port 1(eth0) entered disabled state
[ 1437.720000] eth0: link up (100Mbps/Full duplex)
[ 1437.720000] br-lan: port 1(eth0) entered forwarding state
[ 1437.730000] br-lan: port 1(eth0) entered forwarding state
[ 1439.730000] br-lan: port 1(eth0) entered forwarding state
Like I said I don't really know much about OpenWRT but I'd assume that the issue resides in the absence of the /mnt/usb/PirateBox, /opt/piratebox, /opt/piratebox/version :) Although, I don't really know how to go about getting those files.
If I missed any commands please let me know as I'd be happy to post them. Thank you all for your time and for the read. Have a wonderful rest of your day!
I got the box up and running and a new network appeared on my wifi connection screen. I successfully connected to the network with the SSID, "OpenWRT" but upon opening www.google.com and refreshing many times I was not redirected to the piratebox homepage.
I spent a week or so browsing the forums looking for similar situations to my own. I found many posts with some commands to output to make your lives easier so I've put those at the bottom of this post as well. I'm not too familiar with OpenWRT so please excuse my "noobyness".
root@OpenWrt:~# mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime,size=14592k)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,relatime,lowerdir=/,upperdir=/overlay)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/sda1 on /mnt/usb type vfat (rw,noatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
none on /proc/bus/usb type usbfs (rw,relatime)
root@OpenWrt:~# vi /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.1'
root@OpenWrt:~# ls -la /mnt/
drwxr-xr-x 1 root root 0 Jan 1 00:00 .
drwxr-xr-x 1 root root 0 Jan 1 00:00 ..
drwxrwxrwx 4 root root 512 Jan 1 00:00 usb
root@OpenWrt:~# ls -la /mnt/usb/
drwxrwxrwx 4 root root 512 Jan 1 00:00 .
drwxr-xr-x 1 root root 0 Jan 1 00:00 ..
drwxrwxrwx 2 root root 512 Jan 1 1980 external_fs
drwxrwxrwx 2 root root 512 Jan 1 1980 install
-rwxrwxrwx 1 root root 24225 Jan 1 00:00 install.log
root@OpenWrt:~# ls -la /mnt/usb/PirateBox
ls: /mnt/usb/PirateBox: No such file or directory
root@OpenWrt:~# ls -la /opt/piratebox
ls: /opt/piratebox: No such file or directory
root@OpenWrt:~# cat /opt/piratebox/version
cat: can't open '/opt/piratebox/version': No such file or directory
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option macaddr ec:08:6b:81:45:2a
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
option disabled 0
config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none
root@OpenWrt:~# dmesg | tail -n 20
[ 133.730000] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 135.730000] br-lan: port 1(eth0) entered forwarding state
[ 241.720000] eth0: link down
[ 241.720000] br-lan: port 1(eth0) entered disabled state
[ 269.720000] eth0: link up (100Mbps/Full duplex)
[ 269.720000] br-lan: port 1(eth0) entered forwarding state
[ 269.730000] br-lan: port 1(eth0) entered forwarding state
[ 271.730000] br-lan: port 1(eth0) entered forwarding state
[ 291.720000] eth0: link down
[ 291.720000] br-lan: port 1(eth0) entered disabled state
[ 1001.720000] eth0: link up (100Mbps/Full duplex)
[ 1001.720000] br-lan: port 1(eth0) entered forwarding state
[ 1001.730000] br-lan: port 1(eth0) entered forwarding state
[ 1003.730000] br-lan: port 1(eth0) entered forwarding state
[ 1421.720000] eth0: link down
[ 1421.720000] br-lan: port 1(eth0) entered disabled state
[ 1437.720000] eth0: link up (100Mbps/Full duplex)
[ 1437.720000] br-lan: port 1(eth0) entered forwarding state
[ 1437.730000] br-lan: port 1(eth0) entered forwarding state
[ 1439.730000] br-lan: port 1(eth0) entered forwarding state
Like I said I don't really know much about OpenWRT but I'd assume that the issue resides in the absence of the /mnt/usb/PirateBox, /opt/piratebox, /opt/piratebox/version :) Although, I don't really know how to go about getting those files.
If I missed any commands please let me know as I'd be happy to post them. Thank you all for your time and for the read. Have a wonderful rest of your day!