So I was able to gain access back to the /etc/config/network through failsafe mode and now at the point of editing my network files. However, after various threads and forums there seems to be competing information and I want to make sure I am entering the correct data. BTW, I am operating on a MAC OS and have little background in using terminals so if you have suggestions, please be as explicit as possible. More detail the better!
As of now I have:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
~
~
~
~
~
~
~
~
I /etc/config/network [Modified] 15/15 100%
After option netmask, do I just need to add:
option gateway '192.168.2.1'
list dns '192.168.2.1'
list dns '8.8.8.8'
I am currently working on this as a work project (I work at a University) that has a large network. I have been able to change the MAC laptop I have been working on to the suggested IPv4 192.168.1.2/255.255.255.0/empty field for router
After seeing different ways to configure the network files, I just want to make sure I am doing this correctly! Thanks for the hand holding!
As of now I have:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
~
~
~
~
~
~
~
~
I /etc/config/network [Modified] 15/15 100%
After option netmask, do I just need to add:
option gateway '192.168.2.1'
list dns '192.168.2.1'
list dns '8.8.8.8'
I am currently working on this as a work project (I work at a University) that has a large network. I have been able to change the MAC laptop I have been working on to the suggested IPv4 192.168.1.2/255.255.255.0/empty field for router
After seeing different ways to configure the network files, I just want to make sure I am doing this correctly! Thanks for the hand holding!