mount:
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,relatime,lowerdir=/,upperdir=/overlay)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/sda1 on /mnt/usb type vfat (rw,noatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /mnt/ext type ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)
/dev/loop1 on /opt/piratebox type ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)
none on /proc/bus/usb type usbfs (rw,relatime)
root@piratebox:~# ls -la /mnt/
drwxr-xr-x 1 root root 0 Jan 1 1970 .
drwxr-xr-x 1 root root 0 Jan 1 1970 ..
drwxr-xr-x 7 root root 1024 Jan 1 1970 ext
drwxrwxrwx 5 root root 8192 Jan 1 1970 usb
root@piratebox:~# ls -la /mnt/usb
drwxrwxrwx 5 root root 8192 Jan 1 1970 .
drwxr-xr-x 1 root root 0 Jan 1 1970 ..
drwxrwxrwx 5 root root 8192 Jan 1 1980 PirateBox
drwxrwxrwx 2 root root 8192 Jan 1 1980 external_fs
drwxrwxrwx 3 root root 8192 Jan 1 1980 install
-rwxrwxrwx 1 root root 4998 Jan 1 1980 install.log
-rwxrwxrwx 1 root root 11333946 Dec 16 12:43 install_piratebox.zip
-rwxrwxrwx 1 root root 3932160 Dec 16 12:43 openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
root@piratebox:~# ls -la /mnt/usb/PirateBox/
drwxrwxrwx 5 root root 8192 Jan 1 1980 .
drwxrwxrwx 5 root root 8192 Jan 1 1970 ..
drwxrwxrwx 2 root root 8192 Jan 1 1980 Shared
drwxrwxrwx 11 root root 8192 Jan 1 1980 board
-rwxrwxrwx 1 root root 52428800 Jan 1 1970 pbIMG_ws.img
drwxrwxrwx 2 root root 8192 Jan 1 1980 tmp
root@piratebox:~# ls -la /mnt/usb/install
drwxrwxrwx 3 root root 8192 Jan 1 1980 .
drwxrwxrwx 5 root root 8192 Jan 1 1970 ..
-rwxrwxrwx 1 root root 108547 Oct 10 13:03 OpenWRT.img.gz
-rwxrwxrwx 1 root root 66 Jan 1 1980 auto_package_done
drwxrwxrwx 2 root root 8192 Oct 10 13:03 cache
-rwxrwxrwx 1 root root 222185 Oct 10 13:03 kareha_3.1.4.zip
-rwxrwxrwx 1 root root 189281 Oct 10 13:03 piratebox_ws_1.0_img.tar.gz
root@piratebox:~# ls -la /opt/piratebox/
drwxr-xr-x 10 root root 1024 Jan 1 1970 .
drwxr-xr-x 3 root root 0 Jan 1 1970 ..
drwxr-xr-x 3 root root 1024 Oct 10 08:42 bin
drwxr-xr-x 3 root root 1024 Jan 1 1970 conf
drwxr-xr-x 2 root root 1024 Oct 10 08:42 init.d
drwx------ 2 root root 12288 Jan 16 2014 lost+found
drwxr-xr-x 2 root root 1024 Jan 1 1970 python_lib
lrwxrwxrwx 1 root root 18 Jan 1 1970 share -> /mnt/usb/PirateBox
drwxr-xr-x 2 root root 1024 Oct 10 08:43 src
drwxr-xr-x 2 nobody nogroup 1024 Jan 1 1970 tmp
-rw-r--r-- 1 root root 19 Oct 10 08:43 version
drwxr-xr-x 4 nobody nogroup 1024 Jan 1 1970 www
root@piratebox:~# ls -la /opt/piratebox/www/
drwxr-xr-x 4 nobody nogroup 1024 Jan 1 1970 .
drwxr-xr-x 10 root root 1024 Jan 1 1970 ..
-rwxr-xr-x 1 nobody nogroup 1458 Oct 10 08:43 .READ.ME.htm
lrwxrwxrwx 1 root root 27 Jan 1 1970 Shared -> /opt/piratebox/share/Shared
lrwxrwxrwx 1 root root 26 Jan 1 1970 board -> /opt/piratebox/share/board
drwxr-xr-x 2 nobody nogroup 1024 Oct 10 08:43 cgi-bin
-rw-r--r-- 1 nobody nogroup 289 Jan 1 1970 chat_content.html
-rwxr-xr-x 1 nobody nogroup 1406 Oct 10 08:43 favicon.ico
-rw-r--r-- 1 nobody nogroup 0 Jan 1 1970 forban_link.html
-rwxr-xr-x 1 root root 254 Jan 1 1970 forum.html
-rw-r--r-- 1 nobody nogroup 3776 Oct 10 08:43 index.html
-rwxr-xr-x 1 nobody nogroup 94840 Oct 10 08:43 jquery.min.js
drwxr-xr-x 3 nobody nogroup 1024 Oct 10 08:43 library
-rw-r--r-- 1 nobody nogroup 2992 Oct 10 08:43 menu.png
-rw-r--r-- 1 nobody nogroup 15 Oct 10 08:43 ncsi.txt
-rw-r--r-- 1 nobody nogroup 6607 Oct 10 08:43 piratebox-logo-horizontal-white.png
-rwxr-xr-x 1 nobody nogroup 12637 Oct 10 08:43 piratebox-logo-small.png
-rwxr-xr-x 1 nobody nogroup 201 Oct 10 08:43 redirect.html
-rwxr-xr-x 1 nobody nogroup 3715 Oct 10 08:43 scripts.js
-rw-r--r-- 1 nobody nogroup 0 Oct 10 08:43 station_cnt.txt
-rw-r--r-- 1 nobody nogroup 5040 Oct 10 08:43 style.css
root@piratebox:~# cat /etc/pbx_custom_image
PBX_auto_Image_2.2
root@piratebox:~# cat /etc/openwrt_release
DISTRIB_ID="OpenWrt_backports"
DISTRIB_RELEASE="12.09.2"
DISTRIB_REVISION="r42647"
DISTRIB_CODENAME="attitude_adjustment"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt_backports Attitude Adjustment 12.09.2"
DISTRIB_BACKPORT="V0.2.1"
root@piratebox:~# cat /opt/piratebox/version
piratebox-ws_1.0.1
root@piratebox:~# cat /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option gateway '192.168.1.254'
list dns '192.168.1.254'
list dns '8.8.8.8'
(I tries to add gateway an list dns, normaly there are not here)
root@piratebox:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr 'ff:ff:ff:ff:ff:ff'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'PirateBox - Share Freely'
root@piratebox:~# dmesg | tail -n 20
[ 31.290000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 31.460000] nf_conntrack version 0.5.0 (455 buckets, 1820 max)
[ 31.690000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 31.960000] batman_adv: B.A.T.M.A.N. advanced 2013.4.0 (compatibility version 14) loaded
[ 35.120000] EXT4-fs (loop0): couldn't mount as ext3 due to feature incompatibilities
[ 35.140000] EXT4-fs (loop0): couldn't mount as ext2 due to feature incompatibilities
[ 35.190000] EXT4-fs (loop0): mounted filesystem with ordered data mode. Opts: (null)
[ 35.340000] EXT4-fs (loop1): couldn't mount as ext3 due to feature incompatibilities
[ 35.350000] EXT4-fs (loop1): couldn't mount as ext2 due to feature incompatibilities
[ 35.390000] EXT4-fs (loop1): mounted filesystem with ordered data mode. Opts: (null)
[ 36.810000] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 36.810000] device eth0 entered promiscuous mode
[ 36.820000] ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 37.480000] eth0: link up (100Mbps/Full duplex)
[ 37.480000] br-lan: port 1(eth0) entered forwarding state
[ 37.490000] br-lan: port 1(eth0) entered forwarding state
[ 37.490000] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 37.500000] ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 39.490000] br-lan: port 1(eth0) entered forwarding state
[ 44.670000] Adding 32764k swap on /mnt/usb/external_fs/OpenWRT.swap. Priority:-1 extents:1 across:32764k
root@piratebox:~# ps
PID USER VSZ STAT COMMAND
1 root 1504 S init
2 root 0 SW [kthreadd]
3 root 0 SW [ksoftirqd/0]
4 root 0 SW [kworker/0:0]
5 root 0 SW [kworker/u:0]
6 root 0 SW< [khelper]
7 root 0 SW [kworker/u:1]
63 root 0 SW [sync_supers]
65 root 0 SW [bdi-default]
67 root 0 SW< [kblockd]
96 root 0 SW [kswapd0]
144 root 0 SW [fsnotify_mark]
173 root 0 SW< [ath79-spi]
184 root 0 SW [mtdblock0]
189 root 0 SW [mtdblock1]
194 root 0 SW [mtdblock2]
199 root 0 SW [mtdblock3]
204 root 0 SW [mtdblock4]
209 root 0 SW [mtdblock5]
250 root 0 SW [kworker/0:1]
442 root 0 SWN [jffs2_gcd_mtd3]
472 root 0 SW [khubd]
481 root 0 SW [scsi_eh_0]
482 root 0 SW [usb-storage]
507 root 1504 S init
542 root 0 SW< [cfg80211]
616 root 0 SW< [bat_events]
643 root 1508 S /sbin/syslogd -C16
645 root 1488 S /sbin/klogd
647 root 872 S /sbin/hotplug2 --override --persistent --set-rules-file /etc/hotplug2.rules --set-coldplug-cmd /sbin/udevtrigger --max-children 1
655 root 872 S /sbin/ubusd
729 root 0 SW< [loop0]
734 root 0 SW [jbd2/loop0-8]
735 root 0 SW< [ext4-dio-unwrit]
755 root 0 SW< [loop1]
760 root 0 SW [jbd2/loop1-8]
761 root 0 SW< [ext4-dio-unwrit]
766 root 1468 S /sbin/netifd
1308 root 1152 S /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22
1360 nobody 952 S /usr/sbin/dnsmasq -x /var/run/piratebox_dnsmasq.pid -C /opt/piratebox/conf/dnsmasq_generated.conf
1367 root 8220 S python /opt/piratebox/bin/droopy -H piratebox.lan -d /opt/piratebox/share/Shared -m -c 8080
1419 root 1500 S /sbin/watchdog -t 5 /dev/watchdog
1462 nobody 3552 S /usr/sbin/lighttpd -f /opt/piratebox/conf/lighttpd/lighttpd.conf
1498 root 1500 S /usr/sbin/ntpd -n -p 0.openwrt.pool.ntp.org -p 1.openwrt.pool.ntp.org -p 2.openwrt.pool.ntp.org -p 3.openwrt.pool.ntp.org
1517 root 1216 R /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22
1518 root 1512 S -ash
1535 root 0 SW [flush-7:1]
1536 root 0 SW [flush-8:0]
1548 root 1496 R ps
root@piratebox:~# cat /mnt/usb/install.log
Jan 1 00:00:50 piratebox syslog.info syslogd started: BusyBox v1.19.4
Jan 1 00:00:50 piratebox user.notice root: /bin/box_installer.sh : executing run_test
Jan 1 00:00:50 piratebox user.notice root: /bin/box_installer.sh : Testing requirements...
Jan 1 00:00:50 piratebox user.notice root: /bin/box_installer.sh : .. USB storage modules available
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : extendRoot package is installed
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_signaling_extendRoot_start
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh: line 178: can't create /sys/class/leds/wlan/trigger: nonexistent directory
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_prepare_extendRoot
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : configure initi step for extendRoot
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_init_extendRoot
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : not running extendRoot init, because it already is
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_signaling_extendRoot_stop
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/wlan/trigger: nonexistent directory
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/wlan/brightness: nonexistent directory
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_test_installation_destination
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Testing if installation destination by extendRoot is available.
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Installation destination is available.
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_fake_opkg_update
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Getting main Repository from /etc/opkg.conf
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Doing fake opkg update (copy from cache folder (attitude_adjustment)
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : .. doing it for Piratebox repository (optional)
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : executing run_signaling_package_start
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/3g/trigger: nonexistent directory
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/usb/trigger: nonexistent directory
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : executing run_install_package
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : Installing packge extendRoot-piratebox piratebox-mod-imageboard extendRoot-minidlna
Jan 1 00:00:54 piratebox user.notice root: Package extendRoot-piratebox (0.9.1-3) installed in ext is up to date.
Jan 1 00:00:54 piratebox user.notice root: Package piratebox-mod-imageboard (0.1.3-1) installed in ext is up to date.
Jan 1 00:00:54 piratebox user.notice root: Package extendRoot-minidlna (0.9.1-3) installed in ext is up to date.
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh : executing run_signaling_package_stop
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/3g/trigger: nonexistent directory
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/3g/brightness: nonexistent directory
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/usb/trigger: nonexistent directory
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/usb/brightness: nonexistent directory
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh : executing exit
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,relatime,lowerdir=/,upperdir=/overlay)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/sda1 on /mnt/usb type vfat (rw,noatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /mnt/ext type ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)
/dev/loop1 on /opt/piratebox type ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)
none on /proc/bus/usb type usbfs (rw,relatime)
root@piratebox:~# ls -la /mnt/
drwxr-xr-x 1 root root 0 Jan 1 1970 .
drwxr-xr-x 1 root root 0 Jan 1 1970 ..
drwxr-xr-x 7 root root 1024 Jan 1 1970 ext
drwxrwxrwx 5 root root 8192 Jan 1 1970 usb
root@piratebox:~# ls -la /mnt/usb
drwxrwxrwx 5 root root 8192 Jan 1 1970 .
drwxr-xr-x 1 root root 0 Jan 1 1970 ..
drwxrwxrwx 5 root root 8192 Jan 1 1980 PirateBox
drwxrwxrwx 2 root root 8192 Jan 1 1980 external_fs
drwxrwxrwx 3 root root 8192 Jan 1 1980 install
-rwxrwxrwx 1 root root 4998 Jan 1 1980 install.log
-rwxrwxrwx 1 root root 11333946 Dec 16 12:43 install_piratebox.zip
-rwxrwxrwx 1 root root 3932160 Dec 16 12:43 openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
root@piratebox:~# ls -la /mnt/usb/PirateBox/
drwxrwxrwx 5 root root 8192 Jan 1 1980 .
drwxrwxrwx 5 root root 8192 Jan 1 1970 ..
drwxrwxrwx 2 root root 8192 Jan 1 1980 Shared
drwxrwxrwx 11 root root 8192 Jan 1 1980 board
-rwxrwxrwx 1 root root 52428800 Jan 1 1970 pbIMG_ws.img
drwxrwxrwx 2 root root 8192 Jan 1 1980 tmp
root@piratebox:~# ls -la /mnt/usb/install
drwxrwxrwx 3 root root 8192 Jan 1 1980 .
drwxrwxrwx 5 root root 8192 Jan 1 1970 ..
-rwxrwxrwx 1 root root 108547 Oct 10 13:03 OpenWRT.img.gz
-rwxrwxrwx 1 root root 66 Jan 1 1980 auto_package_done
drwxrwxrwx 2 root root 8192 Oct 10 13:03 cache
-rwxrwxrwx 1 root root 222185 Oct 10 13:03 kareha_3.1.4.zip
-rwxrwxrwx 1 root root 189281 Oct 10 13:03 piratebox_ws_1.0_img.tar.gz
root@piratebox:~# ls -la /opt/piratebox/
drwxr-xr-x 10 root root 1024 Jan 1 1970 .
drwxr-xr-x 3 root root 0 Jan 1 1970 ..
drwxr-xr-x 3 root root 1024 Oct 10 08:42 bin
drwxr-xr-x 3 root root 1024 Jan 1 1970 conf
drwxr-xr-x 2 root root 1024 Oct 10 08:42 init.d
drwx------ 2 root root 12288 Jan 16 2014 lost+found
drwxr-xr-x 2 root root 1024 Jan 1 1970 python_lib
lrwxrwxrwx 1 root root 18 Jan 1 1970 share -> /mnt/usb/PirateBox
drwxr-xr-x 2 root root 1024 Oct 10 08:43 src
drwxr-xr-x 2 nobody nogroup 1024 Jan 1 1970 tmp
-rw-r--r-- 1 root root 19 Oct 10 08:43 version
drwxr-xr-x 4 nobody nogroup 1024 Jan 1 1970 www
root@piratebox:~# ls -la /opt/piratebox/www/
drwxr-xr-x 4 nobody nogroup 1024 Jan 1 1970 .
drwxr-xr-x 10 root root 1024 Jan 1 1970 ..
-rwxr-xr-x 1 nobody nogroup 1458 Oct 10 08:43 .READ.ME.htm
lrwxrwxrwx 1 root root 27 Jan 1 1970 Shared -> /opt/piratebox/share/Shared
lrwxrwxrwx 1 root root 26 Jan 1 1970 board -> /opt/piratebox/share/board
drwxr-xr-x 2 nobody nogroup 1024 Oct 10 08:43 cgi-bin
-rw-r--r-- 1 nobody nogroup 289 Jan 1 1970 chat_content.html
-rwxr-xr-x 1 nobody nogroup 1406 Oct 10 08:43 favicon.ico
-rw-r--r-- 1 nobody nogroup 0 Jan 1 1970 forban_link.html
-rwxr-xr-x 1 root root 254 Jan 1 1970 forum.html
-rw-r--r-- 1 nobody nogroup 3776 Oct 10 08:43 index.html
-rwxr-xr-x 1 nobody nogroup 94840 Oct 10 08:43 jquery.min.js
drwxr-xr-x 3 nobody nogroup 1024 Oct 10 08:43 library
-rw-r--r-- 1 nobody nogroup 2992 Oct 10 08:43 menu.png
-rw-r--r-- 1 nobody nogroup 15 Oct 10 08:43 ncsi.txt
-rw-r--r-- 1 nobody nogroup 6607 Oct 10 08:43 piratebox-logo-horizontal-white.png
-rwxr-xr-x 1 nobody nogroup 12637 Oct 10 08:43 piratebox-logo-small.png
-rwxr-xr-x 1 nobody nogroup 201 Oct 10 08:43 redirect.html
-rwxr-xr-x 1 nobody nogroup 3715 Oct 10 08:43 scripts.js
-rw-r--r-- 1 nobody nogroup 0 Oct 10 08:43 station_cnt.txt
-rw-r--r-- 1 nobody nogroup 5040 Oct 10 08:43 style.css
root@piratebox:~# cat /etc/pbx_custom_image
PBX_auto_Image_2.2
root@piratebox:~# cat /etc/openwrt_release
DISTRIB_ID="OpenWrt_backports"
DISTRIB_RELEASE="12.09.2"
DISTRIB_REVISION="r42647"
DISTRIB_CODENAME="attitude_adjustment"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt_backports Attitude Adjustment 12.09.2"
DISTRIB_BACKPORT="V0.2.1"
root@piratebox:~# cat /opt/piratebox/version
piratebox-ws_1.0.1
root@piratebox:~# cat /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option gateway '192.168.1.254'
list dns '192.168.1.254'
list dns '8.8.8.8'
(I tries to add gateway an list dns, normaly there are not here)
root@piratebox:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr 'ff:ff:ff:ff:ff:ff'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'PirateBox - Share Freely'
root@piratebox:~# dmesg | tail -n 20
[ 31.290000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 31.460000] nf_conntrack version 0.5.0 (455 buckets, 1820 max)
[ 31.690000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 31.960000] batman_adv: B.A.T.M.A.N. advanced 2013.4.0 (compatibility version 14) loaded
[ 35.120000] EXT4-fs (loop0): couldn't mount as ext3 due to feature incompatibilities
[ 35.140000] EXT4-fs (loop0): couldn't mount as ext2 due to feature incompatibilities
[ 35.190000] EXT4-fs (loop0): mounted filesystem with ordered data mode. Opts: (null)
[ 35.340000] EXT4-fs (loop1): couldn't mount as ext3 due to feature incompatibilities
[ 35.350000] EXT4-fs (loop1): couldn't mount as ext2 due to feature incompatibilities
[ 35.390000] EXT4-fs (loop1): mounted filesystem with ordered data mode. Opts: (null)
[ 36.810000] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 36.810000] device eth0 entered promiscuous mode
[ 36.820000] ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 37.480000] eth0: link up (100Mbps/Full duplex)
[ 37.480000] br-lan: port 1(eth0) entered forwarding state
[ 37.490000] br-lan: port 1(eth0) entered forwarding state
[ 37.490000] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 37.500000] ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 39.490000] br-lan: port 1(eth0) entered forwarding state
[ 44.670000] Adding 32764k swap on /mnt/usb/external_fs/OpenWRT.swap. Priority:-1 extents:1 across:32764k
root@piratebox:~# ps
PID USER VSZ STAT COMMAND
1 root 1504 S init
2 root 0 SW [kthreadd]
3 root 0 SW [ksoftirqd/0]
4 root 0 SW [kworker/0:0]
5 root 0 SW [kworker/u:0]
6 root 0 SW< [khelper]
7 root 0 SW [kworker/u:1]
63 root 0 SW [sync_supers]
65 root 0 SW [bdi-default]
67 root 0 SW< [kblockd]
96 root 0 SW [kswapd0]
144 root 0 SW [fsnotify_mark]
173 root 0 SW< [ath79-spi]
184 root 0 SW [mtdblock0]
189 root 0 SW [mtdblock1]
194 root 0 SW [mtdblock2]
199 root 0 SW [mtdblock3]
204 root 0 SW [mtdblock4]
209 root 0 SW [mtdblock5]
250 root 0 SW [kworker/0:1]
442 root 0 SWN [jffs2_gcd_mtd3]
472 root 0 SW [khubd]
481 root 0 SW [scsi_eh_0]
482 root 0 SW [usb-storage]
507 root 1504 S init
542 root 0 SW< [cfg80211]
616 root 0 SW< [bat_events]
643 root 1508 S /sbin/syslogd -C16
645 root 1488 S /sbin/klogd
647 root 872 S /sbin/hotplug2 --override --persistent --set-rules-file /etc/hotplug2.rules --set-coldplug-cmd /sbin/udevtrigger --max-children 1
655 root 872 S /sbin/ubusd
729 root 0 SW< [loop0]
734 root 0 SW [jbd2/loop0-8]
735 root 0 SW< [ext4-dio-unwrit]
755 root 0 SW< [loop1]
760 root 0 SW [jbd2/loop1-8]
761 root 0 SW< [ext4-dio-unwrit]
766 root 1468 S /sbin/netifd
1308 root 1152 S /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22
1360 nobody 952 S /usr/sbin/dnsmasq -x /var/run/piratebox_dnsmasq.pid -C /opt/piratebox/conf/dnsmasq_generated.conf
1367 root 8220 S python /opt/piratebox/bin/droopy -H piratebox.lan -d /opt/piratebox/share/Shared -m -c 8080
1419 root 1500 S /sbin/watchdog -t 5 /dev/watchdog
1462 nobody 3552 S /usr/sbin/lighttpd -f /opt/piratebox/conf/lighttpd/lighttpd.conf
1498 root 1500 S /usr/sbin/ntpd -n -p 0.openwrt.pool.ntp.org -p 1.openwrt.pool.ntp.org -p 2.openwrt.pool.ntp.org -p 3.openwrt.pool.ntp.org
1517 root 1216 R /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22
1518 root 1512 S -ash
1535 root 0 SW [flush-7:1]
1536 root 0 SW [flush-8:0]
1548 root 1496 R ps
root@piratebox:~# cat /mnt/usb/install.log
Jan 1 00:00:50 piratebox syslog.info syslogd started: BusyBox v1.19.4
Jan 1 00:00:50 piratebox user.notice root: /bin/box_installer.sh : executing run_test
Jan 1 00:00:50 piratebox user.notice root: /bin/box_installer.sh : Testing requirements...
Jan 1 00:00:50 piratebox user.notice root: /bin/box_installer.sh : .. USB storage modules available
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : extendRoot package is installed
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_signaling_extendRoot_start
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh: line 178: can't create /sys/class/leds/wlan/trigger: nonexistent directory
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_prepare_extendRoot
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : configure initi step for extendRoot
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_init_extendRoot
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : not running extendRoot init, because it already is
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_signaling_extendRoot_stop
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/wlan/trigger: nonexistent directory
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/wlan/brightness: nonexistent directory
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_test_installation_destination
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Testing if installation destination by extendRoot is available.
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Installation destination is available.
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : executing run_fake_opkg_update
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Getting main Repository from /etc/opkg.conf
Jan 1 00:00:51 piratebox user.notice root: /bin/box_installer.sh : Doing fake opkg update (copy from cache folder (attitude_adjustment)
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : .. doing it for Piratebox repository (optional)
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : executing run_signaling_package_start
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/3g/trigger: nonexistent directory
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/usb/trigger: nonexistent directory
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : executing run_install_package
Jan 1 00:00:52 piratebox user.notice root: /bin/box_installer.sh : Installing packge extendRoot-piratebox piratebox-mod-imageboard extendRoot-minidlna
Jan 1 00:00:54 piratebox user.notice root: Package extendRoot-piratebox (0.9.1-3) installed in ext is up to date.
Jan 1 00:00:54 piratebox user.notice root: Package piratebox-mod-imageboard (0.1.3-1) installed in ext is up to date.
Jan 1 00:00:54 piratebox user.notice root: Package extendRoot-minidlna (0.9.1-3) installed in ext is up to date.
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh : executing run_signaling_package_stop
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/3g/trigger: nonexistent directory
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/3g/brightness: nonexistent directory
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/usb/trigger: nonexistent directory
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh: line 26: can't create /sys/class/leds/usb/brightness: nonexistent directory
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh : Trying to find next step
Jan 1 00:00:54 piratebox user.notice root: /bin/box_installer.sh : executing exit