Hey, Thanks for the input!
Sure, Beers on me :)
I have tried to remove the list dns part (I have added it briefly yesterday by following piratebox video by hommomotamus on youtube)
Here is how my /etc/config/network looks like at the moment:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.101'
option netmask '255.255.255.0'
option gateway '198.168.1.1'
list dns '8.8.8.8'
list dns '8.8.4.4'
#config interface 'wan'
# option ifname 'etho.1'
# option proto 'dhcp'
# option gateway '192.168.1.1'
# option netmask '255.255.255.0'
# list dns '192.168.1.1'
# list dns '8.8.8.8'
root@OpenWrt:~# ping www.google.com
ping: bad address 'www.google.com'
I still get the same error.
Thing to note (if this helps your analysis) is :
my current laptop (lets call it L1) : IP is 192.168.1.3
my OTHER laptop (L2): IP is 192.168.1.4
my router IP is 192.168.1.1
After SSHing to Openwrt (TPLink router) : I am able to Ping
192.168.1.1 & 192.168.1.3
see below:
root@OpenWrt:~# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1): 56 data bytes
64 bytes from 192.168.1.1: seq=0 ttl=64 time=1.354 ms
64 bytes from 192.168.1.1: seq=1 ttl=64 time=0.526 ms
^C
--- 192.168.1.1 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0.526/0.940/1.354 ms
root@OpenWrt:~# ping 192.168.1.3
PING 192.168.1.3 (192.168.1.3): 56 data bytes
64 bytes from 192.168.1.3: seq=0 ttl=128 time=1.697 ms
64 bytes from 192.168.1.3: seq=1 ttl=128 time=97.686 ms
^C
--- 192.168.1.3 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 1.697/49.691/97.686 ms
root@OpenWrt:~# ping 192.168.1.4
PING 192.168.1.4 (192.168.1.4): 56 data bytes
^C
But when I try to ping 192.168.1.4 It just looks like this:
root@OpenWrt:~# ping 192.168.1.4
PING 192.168.1.4 (192.168.1.4): 56 data bytes
(Nothing happens)
Maybe this helps a bit more.
I will be online most of the time over the weekend trying to fix this. please do shout out to me whenever you have some free time :)
Thanks very much, :)
Cheers
Mo
Sure, Beers on me :)
I have tried to remove the list dns part (I have added it briefly yesterday by following piratebox video by hommomotamus on youtube)
Here is how my /etc/config/network looks like at the moment:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.101'
option netmask '255.255.255.0'
option gateway '198.168.1.1'
list dns '8.8.8.8'
list dns '8.8.4.4'
#config interface 'wan'
# option ifname 'etho.1'
# option proto 'dhcp'
# option gateway '192.168.1.1'
# option netmask '255.255.255.0'
# list dns '192.168.1.1'
# list dns '8.8.8.8'
root@OpenWrt:~# ping www.google.com
ping: bad address 'www.google.com'
I still get the same error.
Thing to note (if this helps your analysis) is :
my current laptop (lets call it L1) : IP is 192.168.1.3
my OTHER laptop (L2): IP is 192.168.1.4
my router IP is 192.168.1.1
After SSHing to Openwrt (TPLink router) : I am able to Ping
192.168.1.1 & 192.168.1.3
see below:
root@OpenWrt:~# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1): 56 data bytes
64 bytes from 192.168.1.1: seq=0 ttl=64 time=1.354 ms
64 bytes from 192.168.1.1: seq=1 ttl=64 time=0.526 ms
^C
--- 192.168.1.1 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0.526/0.940/1.354 ms
root@OpenWrt:~# ping 192.168.1.3
PING 192.168.1.3 (192.168.1.3): 56 data bytes
64 bytes from 192.168.1.3: seq=0 ttl=128 time=1.697 ms
64 bytes from 192.168.1.3: seq=1 ttl=128 time=97.686 ms
^C
--- 192.168.1.3 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 1.697/49.691/97.686 ms
root@OpenWrt:~# ping 192.168.1.4
PING 192.168.1.4 (192.168.1.4): 56 data bytes
^C
But when I try to ping 192.168.1.4 It just looks like this:
root@OpenWrt:~# ping 192.168.1.4
PING 192.168.1.4 (192.168.1.4): 56 data bytes
(Nothing happens)
Maybe this helps a bit more.
I will be online most of the time over the weekend trying to fix this. please do shout out to me whenever you have some free time :)
Thanks very much, :)
Cheers
Mo